H5W3
当前位置:H5W3 > 其他技术问题 > 正文

vue-cli中如何正确引入babel-polyfill,如何对import进来的第三方组件生效?

项目引入了Plyr视频播放器组件,在vivo旧机型chrome 39内核上报错了,发现是不支持Array.prototype.find,解决办法是Plyr提供了polyfilled版本,import这个即可

问题是为什么在引入babel-polyfill的情况下,没有对import进来的第三方js组件起作用?

回答:

babel-polyfill用正确的姿势安装之后,引用方式有三种:

1.require(“babel-polyfill”);

2.import “babel-polyfill”;

3.module.exports = {

  entry: [“babel-polyfill”, “./app/js”]

};

注:第三种方法适用于使用webpack构建的同学,加入到webpack配置文件(webpack.config.js)entry项中

重新执行构建命令,在低版本的浏览器中就可以正常打开页面了。

本文地址:H5W3 » vue-cli中如何正确引入babel-polyfill,如何对import进来的第三方组件生效?

评论 0

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址