H5W3
当前位置:H5W3 > 其他技术问题 > 正文

饿了么elementui按需引入文问题

  • 在使用vue配合webpack2打包时出现按需引入elementui组件找不到css样式文件,但是编绎是没有报错
    因为官方说法按需引入要使用.babelrc配制plugins选项

.babelrc配制如下


    {
    "presets": [
        ["es2015", { "modules": false }]
    ],
    "plugins": [
        ["component", [{
            "libraryName": "element-ui",
            "styleLibraryName": "theme-default"
        }]]
    ]
}

webpack配制如下

            {
                test: /\.js$/,
                use: ['babel-loader'],
                exclude: /node_modules/
            },

引入时的代码

    import Vue from 'vue'
    import ResetCss from '../../assets/reset.css'
    import FontCss from '../../assets/font.css'
    // 完整引ele
    import { Button, Card, Form, Input, Checkbox, FormItem } from 'element-ui'
    import App from './App.vue'
    // 加载ele插件
    Vue.use(Button)
    Vue.use(Card)
    Vue.use(Form)
    Vue.use(Input)
    Vue.use(Checkbox)
    Vue.use(FormItem)

回答:

再次排查webpack配制,发现是一个css loader出问题了,还有一定要配制好Extract-Text-Webpack-Plugin这个插件,不然会导致各种问题

本文地址:H5W3 » 饿了么elementui按需引入文问题

评论 0

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址