H5W3
当前位置:H5W3 > 其他技术问题 > 正文

webstorm .vue文件中写sass提示错误,应该怎么配置才能不提示错误。

clipboard.png

回答:

看看你的packpage.json有node-sass吗。没有的话install
或者看看是不是路径问题。

回答:

看一下有没有这个插件,启用了没有。这个应该只是 webstorm 不能识别而已,运行应该是没问题的吧。就算你装了 node-sass,也不能帮助 webstorm 识别语法

clipboard.png

回答:

node-sass也装了 sass support 也勾选了。还是不行。会报语法错误,但是可以正常运行

回答:

clipboard.png
我的相对路径引用正解的话,是没红线的。不过引入npm安装的库,会报语法错误。

回答:

你好,请问你当初解决这个问题了吗?现在我也遇见这个问题了

回答:

解决了

clipboard.png

// 以下,写sass是会提示波浪线的,坑死强迫症
// 但是大多数文档都是这么教的, lang代表代码是sass type又表示代码是css 所以会报错
<style scoped lang="scss" type="text/css"></style>

// 以下 不会提示错误 代表style中所写的sass代码
<style scoped lang="scss"></style>

本文地址:H5W3 » webstorm .vue文件中写sass提示错误,应该怎么配置才能不提示错误。

评论 0

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址