使用如下命令安装,但是vue -V的版本始终是 2.9.6

npm install -g @vue/cli
# OR
yarn global add @vue/cli
$ node -v

v8.12.0

 $  vue -V

2.9.6

尝试 过node重装,无效
npm yarn 全局安装无效,都是最新版本


···回复:

把原先的卸载后再重新安装,关于Vue CLI 3
关于旧版本
Vue CLI 的包名称由 vue-cli 改成了 @vue/cli。 如果你已经全局安装了旧版本的 vue-cli (1.x 或 2.x),你需要先通过 npm uninstall vue-cli -g 或 yarn global remove vue-cli 卸载它。

Node 版本要求
Vue CLI 需要 Node.js 8.9 或更高版本 (推荐 8.11.0+)。你可以使用 nvm 或 nvm-windows 在同一台电脑中管理多个 Node 版本。


···回复:

npm uninstall -g vue-cli
npm install -g @vue/cli
yarn global remove vue-cli
yarn global add @vue/cli

···回复:

应该不行吧,vue-cli3和2都是两个完全不同的版本,何况还是升级cli。除非你重新安装cli,配置相应插件。

Scroll Up