H5W3
当前位置:H5W3 > 其他技术问题 > 正文

centos 升级glibc疑问?

我现在安装vscode提示缺少

./Code: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /usr/local/VSCode-linux-x64/libgcrypt.so.11)
./Code: /lib64/libc.so.6: version `GLIBC_2.15' not found (required by /usr/local/VSCode-linux-x64/libgcrypt.so.11)

然后我下载glibc-2.15.tar.gz、glibc-ports-2.15.tar.gz分别解压安装。
mkdir glibcbuild
cd glibcbuild
../glibc-2.15/configure
make -j4
make install -j4 这里报错,说找不到ld.so.conf,然后我就touch了一个ld.so.conf文件
make install -j4
安装完成,然后我
strings /lib64/libc.so.6 |grep GLIBC_
发现还是没有GLIBC_2.14和GLIBC_2.15 请问怎么破? 我的系统是centos 6.5

回答:

你编译完成后,你编译出来的so在你编译完成的文件夹下的lib里,而系统的so并没有被替换,实际上/lib64/libc.so.6并没有发生任何变化,所以你找不到新的glibc.
正确的做法
可以讲libc.so.6链接到你编译完成后的libc-2.15.so文件,也可以通过临时外部链接库方式解决
例如
export LD_LIBRARY_PATH=/opt/glibc-2.15/lib:$LD_LIBRARY_PATH

回答:

ld.so.conf文件缺少:

cp -r /etc/ld.so.c* /opt/glibc-2.14/etc/
ln -sf /opt/glibc-2.14/lib/libc-2.14.so /lib64/libc.so.6

本文地址:H5W3 » centos 升级glibc疑问?

评论 0

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址