H5W3
当前位置:H5W3 > 其他技术问题 > 正文

centos安装jdk1.8时出现没有/lib/ld-linux.so.2:这个文件的原因分析

-bash: /usr/local/jdk/jdk1.8.0_181/bin/java: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory

安装完后

java -version 查看版本出现: 这里写图片描述

原因是:没有那个文件或目录,找了很久发现需要安装glibc.i686

使用命令:sudo yum install glibc.i686

这里写图片描述

再次查看版本:

这里写图片描述

总结

以上所述是小编给大家介绍的centos安装jdk1.8时出现没有/lib/ld-linux.so.2:这个文件,希望对大家有所帮助,如果大家有任何疑问请给我留言,小编会及时回复大家的。在此也非常感谢大家对网站的支持!

本文地址:H5W3 » centos安装jdk1.8时出现没有/lib/ld-linux.so.2:这个文件的原因分析

评论 0

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址