H5W3
当前位置:H5W3 > 问答 > 正文

Vue在安卓5.0等低版本的IE下如何支持

构建的是App webview H5在安卓5版本的手机上显示不出来项目,由于是小项目,使用的是CDN方式引入的vue,没有用cli,请问应该如何结果低版本兼容的问题?

回答

首先得看两个方案,一个是关键词转义,一个是方法

  • babel 处理 let()=> 等兼容性

    • 可以gulp预先编译一把
    • 也可以script引入之后,用babel转义执行
  • babel-polyfill 处理 Array.fromPromise 等兼容性

    • 直接script引入就好了

当然有一个致命问题,IE8-不支持,因为那个API模拟不出来

首先说一下,vue在安卓5.0不存在兼容性问题,所以你页面不显示和vue没关系,和vue的引入方式更没关系,你最好看下控制台日志,肯定有报错信息,根据报错信息看看具体是哪个js方法报错了,然后针对这个方法做兼容

未经允许不得转载:H5W3 » Vue在安卓5.0等低版本的IE下如何支持

赞 (0)

评论 0

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址