H5W3
当前位置:H5W3 > 问答 > 正文

Angular版本升级出现问题了

概述

我的Angular项目当时创建时是 Angular8.2 ,现在这个项目要继续开发,发现 Angular 已经升级10了,今天升级这个项目出现问题了,我的做法是这样的。

我的升级步骤

  1. 执行 ng update @angular/[email protected] @angular/[email protected] 升级到8版本的最新状态
  2. git add . 然后 commit 提交
  3. 执行 ng update @angular/[email protected] @angular/[email protected] 升级到9,到这一步出现了兼容问题

Angular版本升级出现问题了

我的努力

我的项目中适用了 PrimeNG 和 zorro-antd-design 的两套组件,看上图很明显的给出了是 PrimeNG 不兼容 zone.js ,意思是我要先升级 PrimeNG ?

回答

Angular9.0开始默认启用新的IVY编译方式,如果PrimeNG版本过低的化确实会出现兼容性问题,可以尝试升级
升级注意事项可以在这里查看: https://update.angular.io/?v=…

本文地址:H5W3 » Angular版本升级出现问题了

评论 0

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址