H5W3
当前位置:H5W3 > docker > 正文

【Docker】安装helm失败

问题描述

刚学习K8S. 在 (vagrant 虚拟机) k8s集群环境上安装helm。通过helm version,一直提示如下:
Client: &version.Version{SemVer:”v2.14.1″, GitCommit:”5270352a09c7e8b6e8c9593002a73535276507c0″, GitTreeState:”clean”}
Error: forwarding ports: error upgrading connection: unable to upgrade connection: pod does not exist

问题出现的平台版本及自己尝试过哪些方法

linux, 尝试过修改tiller版本号

相关代码

// 请把代码文本粘贴到下方(请勿用图片代替代码)

通过vagrant搭建了2台虚拟机用于搭建k8s的环境。
192.168.33.111(master)
192.168.33.112(node1)

【Docker】安装helm失败

在master环境安装helm,步骤如下:
1.下载helm-v2.14.1-linux-amd64.tar.gz
2.helm init --service-account tiller --skip-refresh
3.执行kubectl edit deploy tiller-deploy -n kube-system,将 image  gcr.io/kubernetes-helm/tiller:v2.14.1  替换成   image: sapcc/tiller:v2.14.1
4.kubectl get pod -n kube-system -l app=helm
[[email protected] helm]# kubectl get pod -n kube-system -l app=helm

NAME READY STATUS RESTARTS AGE
tiller-deploy-f4ff7c8f9-6fxn9 1/1 Running 0 37m

显示tiller已运行,但helm version后却server却显示错误:

【Docker】安装helm失败

卡了一下午了, 不知道这里是什么原因, 导致helm 这里一直不行。 肯定各位大神帮忙看看

回答

本文地址:H5W3 » 【Docker】安装helm失败

评论 0

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址