Authentication required (packagist.laravel-china.org)

说一说我为什么会更换镜像源,今天我准备给公司的项目添加一个 Excel 导出的功能,需要 PhpSpreadsheet 插件来实现我的功能。输入命令发现提示我 Authentication required (packagist.laravel-china.org):

what?这是什么提示我需要用户名。不对啊平常都没有出现这个问题。我就去查百度了发现原来 laravel-china 的 package 镜像站将要停止运营了,这个消息并不是很好。用了很久的镜像站了,非常不错。哎,人家也坚持了两年已经很不错了。没办法我只能更换了。下面是我更换为阿里云镜像的操作步骤:

官网: https://developer.aliyun.com/composer

全局替换

$ composer config -g repo.packagist composer https://mirrors.aliyun.com/composer/

$ composer clear-cache # 此步奏选泽性操作,清除所有 package 缓存。

当前项目替换

$ cd 项目目录

$ composer config repo.packagist composer https://mirrors.aliyun.com/composer/

以上是 Authentication required (packagist.laravel-china.org) 的全部内容, 来源链接: www.h5w3.com/116263.html

回到顶部