CentOS7.8搭建STF教程

安装命令插件(rz、sz):

yum install -y lrzsz wget unzip zip

编辑配置文件导致命令无法使用时:

export PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin

1.安装JDK

jdk1.8下载地址

新建java目录:mkdir -p /usr/local/java

解压缩下载包:tar -zxvf jdk-8u281-linux-x64.tar.gz

配置环境目录,编辑文件 vi /etc/profile 在文件末添加如下路径:

#java environment

export JAVA_HOME=/usr/local/java/jdk1.8.0_281

export CLASSPATH=.:${JAVA_HOME}/jre/lib/rt.jar:${JAVA_HOME}/lib/dt.jar:${JAVA_HOME}/lib/tools.jar

export PATH=$PATH:${JAVA_HOME}/bin

执行命令查看:java -version,可正常输出即配置成功。

 2.安装Node.js

创建目录 mkdir -p /usr/local/node ,下载安装包:wget https://nodejs.org/download/release/latest-v8.x/node-v8.17.0-linux-x86.tar.gz(选择适合自己系统的包即可uname -a)

解压缩安装包:tar -zxvf node-v8.17.0-linux-x86.tar.gz

添加命令软链接:

ln -s /usr/local/node/node-v8.17.0-linux-x86/bin/node /usr/local/bin

ln -s /usr/local/node/node-v8.17.0-linux-x86/bin/npm /usr/local/bin

使用命令:node -v,npm -v 时报错如下(因为安装了32位软件缺少对应的库,报错详细说明):

-bash: /usr/local/node/node-v8.17.0-linux-x86/bin/node: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory

解决办法执行安装即可:yum install glibc.i686 glibc.x86_64 libstdc++.i686 libstdc++.x86_64 686 glibc.x8664 libstdc + + . i686 libstdc + + . x8664

3.安装RethinkDB(下载地址)

下载安装包:wget https://download.rethinkdb.com/repository/centos/7/x86_64/rethinkdb-2.4.1.x86_64.rpm(很慢的话直接上官网手动下吧)

安装软件包:yum localinstall rethinkdb-2.4.1.x86_64.rpm

查看结果:rethinkdb -v,有输出则安包成功

配置启动:官方文档

复制配置:

sudo cp /etc/rethinkdb/default.conf.sample /etc/rethinkdb/instances.d/instance1.conf

编辑配置(一般改个端口和绑定地址就行):

sudo vim /etc/rethinkdb/instances.d/instance1.conf

启动服务:

sudo /etc/init.d/rethinkdb restart

4.安装ADB命令环境

直接安装:yum install android-tools(很老的版本 可能不适用1.0.31)

需要上墙:官方下载地址 (或直接下载),有sdkmanager工具即可

解压包并配置环境 vi /etc/profile,最后添加如下行:

export PATH=/usr/local/adb/tools/bin:$PATH

sdkmanager --list,查看已安装及可安装包

下载平台工具包,执行如下命令:

sdkmanager "platform-tools"

环境配置:vi /etc/profile,最后添加如下行:

export PATH=/usr/local/adb/platform-tools:$PATH

结果检查:adb --version

 5.安装图像处理库GraphicsMagick

先安装依赖库

yum install -y gcc libpng libjpeg libpng-devel libjpeg-devel ghostscript libtiff libtiff-devel freetype freetype-devel

下载安装包:官方下载地址

 wget https://jaist.dl.sourceforge.net/project/graphicsmagick/graphicsmagick/1.3.36/GraphicsMagick-1.3.36.tar.gz(很慢手动下载吧)

解压安装包:tar -zxvf GraphicsMagick-1.3.36.tar.gz

进入解压包:cd GraphicsMagick

编译安装:

./configure --prefix=/usr/local/GraphicsMagick --with-quantum-depth=8 --enable-shared --enable-static

make && make install

环境配置(vi /etc/profile):

export GM_HOME=/usr/local/GraphicsMagick

export PATH=$PATH:${GM_HOME}/bin

export PATH=$PATH:${GM_HOME}/lib

检查结果:gm version

6.安装必备库(同步骤5 配置时指定下路径./configure --prefix=/usr/local/xxx

  6.1.ZMQ库:下载地址,检查结果(无报错即可):/usr/local/zeromq/bin/curve_keygen version

  6.2.LIBSODIUM库:下载地址,检查结果:whereis libsodium

  6.3.YAML库:下载地址

环境配置:

export PATH=/usr/local/yasm/bin:$PATH

检查结果:yasm --version

  6.4.Protobuf库:下载地址:

执行:autogen.sh,可能报错:configure.ac:109: error: possibly undefined macro: AC_PROG_LIBTOOL,安装libtool即可:yum install libtool

编译安装:以下遇到的问题参考链接

./configure --prefix=/usr/local/protobuf

可能会有如下警告:

configuring in third_party/googletest (/opt/RDB/protobuf-3.15.6/third_party/googletest)

configure: WARNING: no configuration information is in third_party/googletest

缺少google test库:下载地址(用1.8.1的可以,1.10.0 我这不行),把下载的googletest库放到:/opt/RDB/protobuf-3.15.6/third_party/googletest (先删除之前老的),然后再完整来一遍:

autogen.sh

/configure --prefix=/usr/local/protobuf

make

make check(会报一点错,不发现有啥影响 可以忽略)

make install

环境配置:

export PRO_HOME=/usr/local/protobuf

export PATH=$PATH:${PRO_HOME}/bin

export PATH=$PATH:${PRO_HOME}/lib

配置检查:protoc --version

  6.5.PKCONFIG库:下载地址

编译安装:

./configure --prefix=/usr/local/pkg-config --with-internal-glib

make && make install

环境配置:

export PKG_HOME=/usr/local/pkg-config

export PATH=${PKG_HOME}/bin:$PATH

检查结果:pkg-config --version

以上是 CentOS7.8搭建STF教程 的全部内容, 来源链接: www.h5w3.com/122623.html

回到顶部